Image Upload to Use Case Failure

Incident Report for Casebase

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 12:07 CEST

Investigating

Users are unable to successfully upload images, and the process does not complete as expected. The issue has been identified and is under investigation by the technical team.
Posted Apr 14, 2026 - 15:37 CEST
This incident affected: Create and Edit Content.